Суббота, 03.12.2022, 05:11
| RSS
Главная | Глюки и Баги Raspberry Pi, WebHomePi и пользователей - Страница 10 - Форум
Защита, контроль, управление
Форма входа
Логин:
Пароль:
[ Новые сообщения · Участники · Правила форума · Поиск · RSS · Чат

Наш канал в YouTube
]
  • Страница 10 из 10
  • «
  • 1
  • 2
  • 8
  • 9
  • 10
Форум » ФОРУМ » Домашняя автоматизация на Raspberry Pi » Глюки и Баги Raspberry Pi, WebHomePi и пользователей
Глюки и Баги Raspberry Pi, WebHomePi и пользователей
v193073Дата: Понедельник, 19.08.2019, 15:15 | Сообщение # 91
Группа: Пользователи
Сообщений: 12
Статус: Offline
Цитата Admin ()
2. Определяем в sys/bus/w1/devices/ id своего подключенного датчика


вот пункт 2. у меня и не получается сделать при каждой перезагрузки (открытии по новой) sys/bus/w1/devices/id выдаётся разный,............и что мне уж совсем непонятно это когда я  вожу из sys/bus/.....id (первый) в интерфейс DS18B20#1 то вебинтерфейс исчезает и перестаёт работать(не открывается) до полной переустановке WebHomePi на флэшке  .........три раза переустанавливал!!!!!!

и вот сейчас когда я вам пишу и опять из за того что я ввёл неправильный id датчика вебинтерфейс опять исчез и не открывается.........даже если предположить что мой датчик DS18B20 не рабочий и выдаёт постоянно новые id то программа вроде не должна исчезать(WEBhomePI)........ЧЕРТОВЩИНА КАКАЯ ТО!!!!!!!!!!!!!!!!


Сообщение отредактировал v193073 - Понедельник, 19.08.2019, 16:24
 
AdminДата: Понедельник, 19.08.2019, 17:33 | Сообщение # 92
Admin
Группа: Администраторы
Сообщений: 4255
Статус: Offline
Цитата v193073 ()
у меня и не получается сделать при каждой перезагрузки (открытии по новой) sys/bus/w1/devices/id выдаётся разный

ID датчика не может меняться. Но если происходит такая "свистопляска", то могу предположить два варианта:
1. Датчик неисправный.
2. Датчик неправильно подключен (или отсутствует подтягивающий резистор 4,7 кОм). Да и питание не помешает проверить.

Цитата v193073 ()
до полной переустановке WebHomePi на флэшке  .........три раза переустанавливал!!!!!!

Толку с этих переустановок. Нужно искать причину. Запускайте в терминалке отладку и смотрите, какие ошибки возвращаются при недоступном web-интерфейсе. Посмотрите конфигурационный файл (home/pi/myproject/html/config/config.txt), возможно записали туда пустые строки при конфигурировании.

Гадать тут можно до бесконечности. Без описания ошибок я вряд ли чем-то смогу помочь. Но если хотите, могу удаленно покопаться через Тимвьювер.

P.S. Кстати, какая "малина"и какая версия WHP используется?
 
v193073Дата: Вторник, 20.08.2019, 10:41 | Сообщение # 93
Группа: Пользователи
Сообщений: 12
Статус: Offline
Цитата Admin ()
Запускайте в терминалке отладку и смотрите, какие ошибки возвращаются при недоступном web-интерфейсе. Посмотрите конфигурационный файл (home/pi/myproject/html/config/config.txt), возможно записали туда пустые строки при конфигурировании.


да именно так и есть пустые строки в первом идентификаторе, попытался заменить на 28-051694d9d0ff не получается

я так понимаю внутри WinSCP нужно произвести настройки для разрешения переделки файла config.txt но как?.............и поможет ли это??? наверняка при замене id в вебинтерфейсе он меняется в других файлах....

малинка у меня Pi 3 model B
WHP -  WebHomePi_25_11_18

Добавлено (20.08.2019, 11:01)
---------------------------------------------
Прикрепления: 8532727.rtf(3.1 Kb)


Сообщение отредактировал v193073 - Вторник, 20.08.2019, 11:06
 
AdminДата: Вторник, 20.08.2019, 11:32 | Сообщение # 94
Admin
Группа: Администраторы
Сообщений: 4255
Статус: Offline
Цитата v193073 ()
да именно так и есть пустые строки в первом идентификаторе

Следовательно, он туда не записался. А если строка осталась пустой, то при следующей перезагрузке скрипт не может прочитать данные, поэтому интерфейс и становится недоступным. А вот почему не записалось - получается, что делается неправильно. Я давал ссылку на видео, нужно делать все в соответствии с ним и все получится.

Цитата v193073 ()
нужно произвести настройки для разрешения переделки файла config.txt но как?

Я уже вроде бы говорил. что не нужно влезать ни в какие файлы и что-то там править. Все настройки выполняются на уровне web-интерфейса.
Предлагаю еще раз - могу удаленно посмотреть через Тимьвьювер. Например, сегодня где-то в 18-19.00 по мск.
 
AdminДата: Вторник, 20.08.2019, 17:54 | Сообщение # 95
Admin
Группа: Администраторы
Сообщений: 4255
Статус: Offline
Цитата Admin ()
Предлагаю еще раз - могу удаленно посмотреть через Тимьвьювер. Например, сегодня где-то в 18-19.00 по мск

Ну, нет - значит нет.
 


v193073Дата: Вторник, 27.08.2019, 08:53 | Сообщение # 96
Группа: Пользователи
Сообщений: 12
Статус: Offline
Цитата Admin ()
Предлагаю еще раз - могу удаленно посмотреть через Тимьвьювер. Например, сегодня где-то в 18-19.00 по мск

...да нет просто хотелось бы самому разобраться(поковыряться)....а уж потом если не получится можно и удалённо посмотреть
 
BolikStavДата: Вторник, 27.08.2019, 23:39 | Сообщение # 97
Группа: Пользователи
Сообщений: 3
Статус: Offline
Цитата v193073 ()
pi@raspberrypi:~ $ sudo webiopi  /etc/webiopi/configTraceback (most recent call last):

  File "/usr/lib/python3.7/runpy.py", line 183, in _run_module_as_main

    mod_name, mod_spec, code = _get_module_details(mod_name, _Error)

  File "/usr/lib/python3.7/runpy.py", line 142, in _get_module_details

    return _get_module_details(pkg_main_name, error)

  File "/usr/lib/python3.7/runpy.py", line 109, in _get_module_details

    __import__(pkg_name)

  File "/usr/local/lib/python3.7/dist-packages/WebIOPi-0.7.1-py3.7-linux-armv7l.        egg/webiopi/__init__.py", line 20, in <module>

    from webiopi.utils.thread import runLoop

  File "/usr/local/lib/python3.7/dist-packages/WebIOPi-0.7.1-py3.7-linux-armv7l.        egg/webiopi/utils/thread.py", line 36

    def runLoop(func=None, async=False):

                               ^

SyntaxError: invalid syntax

Кто смог победить эту ошибку?
 
AdminДата: Пятница, 30.08.2019, 08:49 | Сообщение # 98
Admin
Группа: Администраторы
Сообщений: 4255
Статус: Offline
Цитата BolikStav ()
Кто смог победить эту ошибку?

Я уже неоднократно говорил - используйте WHP. В WebIOPi точно больше копаться не собираюсь, все что нужно было сделать для адаптации ее под новые ОС, давно реализовано в WHP.
 
BolikStavДата: Пятница, 30.08.2019, 11:50 | Сообщение # 99
Группа: Пользователи
Сообщений: 3
Статус: Offline
Цитата Admin ()
Я уже неоднократно говорил - используйте WHP

Так много изменений? Поделитесь свежей версией, пожалуйста
 
AdminДата: Пятница, 30.08.2019, 13:00 | Сообщение # 100
Admin
Группа: Администраторы
Сообщений: 4255
Статус: Offline
Цитата BolikStav ()
Так много изменений? Поделитесь свежей версией, пожалуйста

Все ссылки здесь - http://lock.3dn.ru/index/soderzhanie_statej_po_raspberry_pi/0-81
Используйте последнюю версию 02_19

Видеоинструкция по настройке системы (правда, не последней версии, но принципиальных отличий нет) здесь:

 
Форум » ФОРУМ » Домашняя автоматизация на Raspberry Pi » Глюки и Баги Raspberry Pi, WebHomePi и пользователей
  • Страница 10 из 10
  • «
  • 1
  • 2
  • 8
  • 9
  • 10
Поиск:



T2M © 2022
Сайт управляется системой uCoz